diff configure.in @ 991:3dbc2cd326e2

[gaim-migrate @ 1001] check for getopt, and --disable-multi (which doesn't actually disable it, it just makes it inaccessible from the GUI) committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Fri, 13 Oct 2000 21:05:50 +0000
parents 7e231bc0018a
children 66481301d972
line wrap: on
line diff
--- a/configure.in	Fri Oct 13 20:50:45 2000 +0000
+++ b/configure.in	Fri Oct 13 21:05:50 2000 +0000
@@ -31,11 +31,16 @@
 AC_CHECK_FUNCS(socket strdup strstr atexit getaddrinfo)
 AC_TRY_COMPILE(sys/socket.h, typedef unsigned int socklen_t;, AC_DEFINE(NEED_SOCKLEN_T),)
 
+dnl Checks for getopt in standard library
+AC_CHECK_FUNCS(getopt_long , , [LIBOBJS="$LIBOBJS getopt.o getopt1.o"] ) 
+AC_SUBST(LIBOBJS)
+
 dnl This is a bad, bad hack.  I am a bad, bad man.
 CFLAGS="$CFLAGS -I/usr/local/include -I/opt/include -I../"
 
 AC_ARG_ENABLE(distrib,,,enable_distrib=no)
 AM_CONDITIONAL(DISTRIB, test "x$enable_distrib" = "xyes")
+AC_ARG_ENABLE(multi,   [  --disable-multi         disable multiple connections],enable_multi=no,enable_multi=yes)
 AC_ARG_ENABLE(gnome,   [  --disable-gnome         compile without Gnome bits],enable_gnome=no,enable_gnome=yes)
 AC_ARG_ENABLE(panel,   [  --enable-panel          compile as a GNOME applet],,enable_panel=$enable_distrib)
 AM_CONDITIONAL(GNOMEAPPLET, test "x$enable_panel" = "xyes")
@@ -98,6 +103,10 @@
 	AC_PATH_PROG(gaimpath, gaim)
 fi
 
+if test "x$enable_multi" != "xyes" ; then
+	AC_DEFINE(NO_MULTI)
+fi
+
 CFLAGS="$CFLAGS $GTK_CFLAGS"
 
 dnl Even more X-Chat code