diff plugins/ticker/Makefile.am @ 3391:412d1035d666

[gaim-migrate @ 3410] Pluginzed the ticker. the ticker will load itself if the old ticker option was set. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Sun, 11 Aug 2002 06:42:17 +0000
parents
children 8d211ff092cb
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/plugins/ticker/Makefile.am	Sun Aug 11 06:42:17 2002 +0000
@@ -0,0 +1,25 @@
+CFLAGS += -I\$(top_srcdir) -I\$(top_srcdir)/src -DVERSION=\"$(VERSION)\"
+plugindir = $(libdir)/gaim
+
+if PLUGINS
+
+tickersources = ticker.c gtkticker.so
+
+all:
+	$(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c gtkticker.c -o tmpgtkticker.lo $(PLUGIN_CFLAGS)
+	$(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c ticker.c -o tmpticker.lo $(PLUGIN_CFLAGS)	
+	$(LIBTOOL) --mode=link    $(CC) $(CFLAGS) -o libtmpticker.la -rpath $(plugindir) tmpgtkticker.lo tmpticker.lo $(LIBS) $(LDFLAGS) -module -avoid-version $(PLUGIN_LIBS)
+	@rm -f tmpticker.lo tmpgtkticker.lo tmpticker.o tmpgtkticker.o libtmpgtkticker.la libticker.la
+	@cp .libs/libtmpticker.so* ticker.so
+	@rm -f .libs/libtmpticker.*
+
+clean distclean:
+	rm -rf $(plugin_DATA) .libs
+
+install:
+	cp ticker.so $(plugindir)
+
+
+endif
+
+EXTRA_DIST = ticker.c gtkticker.c gtkticker.h