diff src/protocols/icq/Makefile.am @ 2086:424a40f12a6c

[gaim-migrate @ 2096] moving protocols from plugins/ to src/protocols. making it so that you can select which protocols are compiled statically. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 31 Jul 2001 01:00:39 +0000
parents
children cf68ddc50ba2
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/icq/Makefile.am	Tue Jul 31 01:00:39 2001 +0000
@@ -0,0 +1,112 @@
+EXTRA_DIST =	AUTHORS \
+		COPYING \
+		ChangeLog \
+		INSTALL \
+		README \
+		VERSION
+
+pkgdir = $(libdir)/gaim
+
+CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+
+if STATIC_ICQ
+
+st = -DSTATIC
+pkg_LTLIBRARIES =
+noinst_LIBRARIES = libicq.a
+
+libicq_a_SOURCES = 	chatsession.c \
+			chatsession.h \
+			contacts.c \
+			contacts.h \
+			cyrillic.c \
+			eventhandle.c \
+			eventhandle.h \
+			filesession.c \
+			filesession.h \
+			icq.h \
+			icqbyteorder.c \
+			icqbyteorder.h \
+			icqevent.c \
+			icqevent.h \
+			icqlib.c \
+			icqlib.h \
+			icqpacket.c \
+			icqpacket.h \
+			icqtypes.h \
+			list.c \
+			list.h \
+			proxy.c \
+			queue.c \
+			queue.h \
+			socketmanager.c \
+			socketmanager.h \
+			stdpackets.c \
+			stdpackets.h \
+			tcp.c \
+			tcp.h \
+			tcpchathandle.c \
+			tcpfilehandle.c \
+			tcphandle.c \
+			tcplink.c \
+			tcplink.h \
+			timeout.c \
+			timeout.h \
+			udp.c \
+			udp.h \
+			udphandle.c \
+			util.c \
+			util.h \
+			gaim_icq.c
+
+else
+
+st =
+pkg_LTLIBRARIES = libgaimicq.la
+noinst_LIBRARIES =
+
+libgaimicq_la_SOURCES =	chatsession.c \
+			chatsession.h \
+			contacts.c \
+			contacts.h \
+			cyrillic.c \
+			eventhandle.c \
+			eventhandle.h \
+			filesession.c \
+			filesession.h \
+			icq.h \
+			icqbyteorder.c \
+			icqbyteorder.h \
+			icqevent.c \
+			icqevent.h \
+			icqlib.c \
+			icqlib.h \
+			icqpacket.c \
+			icqpacket.h \
+			icqtypes.h \
+			list.c \
+			list.h \
+			proxy.c \
+			queue.c \
+			queue.h \
+			socketmanager.c \
+			socketmanager.h \
+			stdpackets.c \
+			stdpackets.h \
+			tcp.c \
+			tcp.h \
+			tcpchathandle.c \
+			tcpfilehandle.c \
+			tcphandle.c \
+			tcplink.c \
+			tcplink.h \
+			timeout.c \
+			timeout.h \
+			udp.c \
+			udp.h \
+			udphandle.c \
+			util.c \
+			util.h \
+			gaim_icq.c
+
+endif