diff src/protocols/yahoo/Makefile.am @ 2086:424a40f12a6c

[gaim-migrate @ 2096] moving protocols from plugins/ to src/protocols. making it so that you can select which protocols are compiled statically. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 31 Jul 2001 01:00:39 +0000
parents
children 5486d558ecee
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/yahoo/Makefile.am	Tue Jul 31 01:00:39 2001 +0000
@@ -0,0 +1,25 @@
+EXTRA_DIST = AUTHORS
+
+pkgdir = $(libdir)/gaim
+
+CFLAGS += -I\$(top_srcdir)/src $(st) $(DEBUG_CFLAGS)
+
+if STATIC_YAHOO
+
+st = -DSTATIC
+pkg_LTLIBRARIES =
+noinst_LIBRARIES = libyahoo.a
+
+libyahoo_a_SOURCES = \
+	buddy.c conn.c internal.h login.c misc.c outgoing.c rxhandlers.c yay.c yay.h
+
+else
+
+st =
+pkg_LTLIBRARIES = libyahoo.la
+noinst_LIBRARIES =
+
+libyahoo_la_SOURCES = \
+	buddy.c conn.c internal.h login.c misc.c outgoing.c rxhandlers.c yay.c yay.h
+
+endif