diff src/protocols/zephyr/Makefile.am @ 2086:424a40f12a6c

[gaim-migrate @ 2096] moving protocols from plugins/ to src/protocols. making it so that you can select which protocols are compiled statically. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Tue, 31 Jul 2001 01:00:39 +0000
parents
children 5486d558ecee
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/zephyr/Makefile.am	Tue Jul 31 01:00:39 2001 +0000
@@ -0,0 +1,147 @@
+pkgdir = $(libdir)/gaim
+
+CFLAGS += -I\$(top_srcdir)/src -I\$(top_srcdir)/src/protocols -DCONFDIR=\"$(confdir)\" $(KRB4_CFLAGS) $(st) $(DEBUG_CFLAGS)
+
+LIBS += $(KRB4_LDFLAGS) $(KRB4_LIBS)
+
+if STATIC_ZEPHYR
+
+st = -DSTATIC
+pkg_LTLIBRARIES =
+noinst_LIBRARIES = libzephyr.a
+
+libzephyr_a_SOURCES = \
+			ZAsyncLocate.c \
+			ZCkAuth.c \
+			ZCkIfNot.c \
+			ZClosePort.c \
+			ZCmpUID.c \
+			ZCmpUIDP.c \
+			ZFlsLocs.c \
+			ZFlsSubs.c \
+			ZFmtAuth.c \
+			ZFmtList.c \
+			ZFmtNotice.c \
+			ZFmtRaw.c \
+			ZFmtRawLst.c \
+			ZFmtSmRLst.c \
+			ZFmtSmRaw.c \
+			ZFreeNot.c \
+			ZGetLocs.c \
+			ZGetSender.c \
+			ZGetSubs.c \
+			ZGetWGPort.c \
+			ZIfNotice.c \
+			ZInit.c \
+			ZLocations.c \
+			ZMakeAscii.c \
+			ZMkAuth.c \
+			ZNewLocU.c \
+			ZOpenPort.c \
+			ZParseNot.c \
+			ZPeekIfNot.c \
+			ZPeekNot.c \
+			ZPeekPkt.c \
+			ZPending.c \
+			ZReadAscii.c \
+			ZRecvNot.c \
+			ZRecvPkt.c \
+			ZRetSubs.c \
+			ZSendList.c \
+			ZSendNot.c \
+			ZSendPkt.c \
+			ZSendRLst.c \
+			ZSendRaw.c \
+			ZSetDest.c \
+			ZSetFD.c \
+			ZSetSrv.c \
+			ZSubs.c \
+			ZVariables.c \
+			ZWait4Not.c \
+			Zinternal.c \
+			com_err.h \
+			error_message.c \
+			error_table.h \
+			et_name.c \
+			init_et.c \
+			internal.h \
+			mit-copyright.h \
+			mit-sipb-copyright.h \
+			sysdep.h \
+			zephyr.h \
+			zephyr_err.c \
+			zephyr_err.h \
+			\
+			zephyr.c
+
+else
+
+st =
+pkg_LTLIBRARIES = libzephyr.la
+noinst_LIBRARIES =
+
+libzephyr_la_SOURCES = \
+			ZAsyncLocate.c \
+			ZCkAuth.c \
+			ZCkIfNot.c \
+			ZClosePort.c \
+			ZCmpUID.c \
+			ZCmpUIDP.c \
+			ZFlsLocs.c \
+			ZFlsSubs.c \
+			ZFmtAuth.c \
+			ZFmtList.c \
+			ZFmtNotice.c \
+			ZFmtRaw.c \
+			ZFmtRawLst.c \
+			ZFmtSmRLst.c \
+			ZFmtSmRaw.c \
+			ZFreeNot.c \
+			ZGetLocs.c \
+			ZGetSender.c \
+			ZGetSubs.c \
+			ZGetWGPort.c \
+			ZIfNotice.c \
+			ZInit.c \
+			ZLocations.c \
+			ZMakeAscii.c \
+			ZMkAuth.c \
+			ZNewLocU.c \
+			ZOpenPort.c \
+			ZParseNot.c \
+			ZPeekIfNot.c \
+			ZPeekNot.c \
+			ZPeekPkt.c \
+			ZPending.c \
+			ZReadAscii.c \
+			ZRecvNot.c \
+			ZRecvPkt.c \
+			ZRetSubs.c \
+			ZSendList.c \
+			ZSendNot.c \
+			ZSendPkt.c \
+			ZSendRLst.c \
+			ZSendRaw.c \
+			ZSetDest.c \
+			ZSetFD.c \
+			ZSetSrv.c \
+			ZSubs.c \
+			ZVariables.c \
+			ZWait4Not.c \
+			Zinternal.c \
+			com_err.h \
+			error_message.c \
+			error_table.h \
+			et_name.c \
+			init_et.c \
+			internal.h \
+			mit-copyright.h \
+			mit-sipb-copyright.h \
+			sysdep.h \
+			zephyr.h \
+			zephyr_err.c \
+			zephyr_err.h \
+			\
+			zephyr.c
+
+endif