diff libpurple/protocols/qq/Makefile.am @ 29265:485f69e04d6a

Fix 'make check' on OS X by adding in a not-installed libqq shared lib. Fix pointed out by David Fang on the mailing list. committer: Paul Aurich <paul@darkrain42.org>
author fang@csl.cornell.edu
date Wed, 13 Jan 2010 08:05:31 +0000
parents a5628ba3c83c
children
line wrap: on
line diff
--- a/libpurple/protocols/qq/Makefile.am	Wed Jan 13 03:13:26 2010 +0000
+++ b/libpurple/protocols/qq/Makefile.am	Wed Jan 13 08:05:31 2010 +0000
@@ -65,12 +65,19 @@
 else
 
 st =
+noinst_LTLIBRARIES =
 pkg_LTLIBRARIES  = libqq.la
 libqq_la_SOURCES = $(QQSOURCES)
 libqq_la_LIBADD  = $(GLIB_LIBS)
 
 endif
 
+# For 'make check'
+noinst_LTLIBRARIES += libqq_tmp.la
+libqq_tmp_la_SOURCES = $(libqq_la_SOURCES)
+libqq_tmp_la_LIBADD = $(libqq_la_LIBADD)
+
+
 # QQ_BUDDY_ICON_DIR is the path where a bunch of stock icons can be
 # places for users to choose from when setting their buddy icon.  We
 # don't distribute those icons ourselves because of possibly copyright