diff plugins/Makefile.am @ 6302:511003c99302

[gaim-migrate @ 6801] Notify plugin. It seems to work pretty well for me. One thing I did notice, it doesn't really handle getting IMs from different people very well. It makes a different counter in title of the IM for each person, and then only updates the most recently added one. I also didn't try chat stuff at all, but I need to go to sleep pretty soon. Pretty much all of the changes were done by Brian Tarricon, I just renamed a few things and did a few other patent-pending actions. committer: Tailor Script <tailor@pidgin.im>
author Mark Doliner <mark@kingant.net>
date Fri, 25 Jul 2003 04:30:52 +0000
parents 6e2f46de5e38
children 9b2c2495687a
line wrap: on
line diff
--- a/plugins/Makefile.am	Thu Jul 24 22:35:26 2003 +0000
+++ b/plugins/Makefile.am	Fri Jul 25 04:30:52 2003 +0000
@@ -9,43 +9,47 @@
 plugindir = $(libdir)/gaim
 
 autorecon_la_LDFLAGS   = -module -avoid-version
+history_la_LDFLAGS     = -module -avoid-version
 iconaway_la_LDFLAGS    = -module -avoid-version
-#notify_la_LDFLAGS      = -module -avoid-version
+idle_la_LDFLAGS        = -module -avoid-version
+notify_la_LDFLAGS      = -module -avoid-version
 spellchk_la_LDFLAGS    = -module -avoid-version
-history_la_LDFLAGS     = -module -avoid-version
+statenotify_la_LDFLAGS = -module -avoid-version
 timestamp_la_LDFLAGS   = -module -avoid-version
-idle_la_LDFLAGS        = -module -avoid-version
-statenotify_la_LDFLAGS = -module -avoid-version
 
 if PLUGINS
 
 plugin_LTLIBRARIES = \
 	autorecon.la   \
+	history.la     \
 	iconaway.la    \
+	idle.la        \
+	notify.la      \
 	spellchk.la    \
-	history.la     \
-	timestamp.la   \
-	idle.la        \
-	statenotify.la
-
-#	notify.la
+	statenotify.la \
+	timestamp.la
 
 autorecon_la_SOURCES   = autorecon.c
+history_la_SOURCES     = history.c
 iconaway_la_SOURCES    = iconaway.c
-#notify_la_SOURCES      = notify.c
+idle_la_SOURCES        = idle.c
+notify_la_SOURCES      = notify.c
 spellchk_la_SOURCES    = spellchk.c
-history_la_SOURCES     = history.c
+statenotify_la_SOURCES = statenotify.c
 timestamp_la_SOURCES   = timestamp.c
-idle_la_SOURCES        = idle.c
-statenotify_la_SOURCES = statenotify.c
 
 endif # PLUGINS
 
 EXTRA_DIST = \
 	ChangeLog PERL-HOWTO HOWTO SIGNALS \
-	filectl.c mailchk.c gtik.c \
-	raw.c events.c simple.c \
-	gaim.pl fortuneprofile.pl
+	filectl.c \
+	mailchk.c \
+	gtik.c \
+	raw.c \
+	events.c \
+	simple.c \
+	gaim.pl \
+	fortuneprofile.pl
 
 AM_CPPFLAGS = \
 	-I$(top_srcdir)/src \