diff configure.ac @ 29766:529233281dfe

network: Use getifaddrs() to enumerate local interfaces/IPs if available. On Linux, it seems SIOCGIFCONF just doesn't support IPv6, and various systems have getifaddrs(), so here we are. Fixes #10160.
author Paul Aurich <paul@darkrain42.org>
date Tue, 16 Feb 2010 02:21:33 +0000
parents 5dec9d90fb51
children f3745c3198b2
line wrap: on
line diff
--- a/configure.ac	Tue Feb 16 00:50:34 2010 +0000
+++ b/configure.ac	Tue Feb 16 02:21:33 2010 +0000
@@ -211,6 +211,7 @@
 	[AC_CHECK_LIB(socket, getaddrinfo,
 		[AC_DEFINE([HAVE_GETADDRINFO]) LIBS="-lsocket -lsnl $LIBS"], , , -lnsl)])
 AC_CHECK_FUNCS(inet_ntop)
+AC_CHECK_FUNCS(getifaddrs)
 dnl Check for socklen_t (in Unix98)
 AC_MSG_CHECKING(for socklen_t)
 AC_TRY_COMPILE([