diff Makefile.am @ 24294:5ace6c024230

propagate from branch 'im.pidgin.pidgin' (head 7821a3549d7d99473e999dc067afc4218addcc1e) to branch 'local.struct.hiding' (head 4235f268e41a5ad75efa1010b697599c0c0dd28a)
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Fri, 31 Oct 2008 07:59:46 +0000
parents cb0aa91430bb
children b31d2ca01b7a
line wrap: on
line diff
--- a/Makefile.am	Sat Oct 04 21:46:10 2008 +0000
+++ b/Makefile.am	Fri Oct 31 07:59:46 2008 +0000
@@ -34,6 +34,9 @@
 # We don't want to release development versions.
 	test x`echo $(PACKAGE_VERSION) | grep dev` = x
 
+# Make sure there is a NEWS entry for this version
+	head NEWS | grep "^$(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" > /dev/null
+
 # Ensure NEWS has no spaces at the start of a line.
 # Using spaces instead of tabs there is a common mistake.
 	test x`grep "^ " NEWS` = x
@@ -45,16 +48,16 @@
 # For all releases, check the ChangeLogs.
 	head ChangeLog | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
 	head ChangeLog.win32 | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
-	head po/ChangeLog | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
+	head po/ChangeLog | grep "^version $(PACKAGE_VERSION)$$" >/dev/null
 
 # Ensure we're working from a tag...
 	test x`mtn automate select t:v$(PACKAGE_VERSION)` = x`mtn automate get_base_revision_id`
 # ... and have no changes in the working copy.
 	test x`mtn diff | grep -v '^#'` = x
 
-release: distcheck packages
+release: version-check distcheck packages
 
-packages: version-check
+packages:
 	gpg -ab pidgin-$(PACKAGE_VERSION).tar.gz
 	gpg -ab pidgin-$(PACKAGE_VERSION).tar.bz2
 	gpg --verify pidgin-$(PACKAGE_VERSION).tar.gz.asc pidgin-$(PACKAGE_VERSION).tar.gz