diff Makefile.am @ 13179:5adc0c9da9f3

[gaim-migrate @ 15542] SF Patch #1265514 This patch adds intltool integration. It works here; let me know if it breaks anything for you. committer: Tailor Script <tailor@pidgin.im>
author Richard Laager <rlaager@wiktel.com>
date Wed, 08 Feb 2006 07:44:23 +0000
parents d10050950c03
children 7ff1d941f8e5
line wrap: on
line diff
--- a/Makefile.am	Wed Feb 08 07:09:41 2006 +0000
+++ b/Makefile.am	Wed Feb 08 07:44:23 2006 +0000
@@ -4,9 +4,12 @@
 		gaim.pc.in \
 		gaim.spec.in \
 		gaim.apspec.in \
-		gaim.desktop \
+		gaim.desktop.in \
 		gaim-installer.nsi \
 		HACKING \
+		intltool-extract.in \
+		intltool-merge.in \
+		intltool-update.in \
 		PROGRAMMING_NOTES \
 		setup-gettext \
 		ChangeLog.win32 \
@@ -36,9 +39,11 @@
 #	cp plugins/perl/common/Gaim.pm $(distdir)/plugins/perl/common
 
 appsdir = $(datadir)/applications
-apps_DATA = gaim.desktop
+apps_in_files = gaim.desktop.in
+apps_DATA = $(apps_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
 
-SUBDIRS = doc intl m4macros pixmaps plugins po sounds src
+SUBDIRS = doc m4macros pixmaps plugins po sounds src
 
 docs: Doxyfile
 if HAVE_DOXYGEN