diff configure.ac @ 21297:5b1acbab99cf

Make purple.h a generated file so plugins can just include this and never worry about defining PURPLE_PLUGINS ever again (unless they build libpurple without plugin support, which would be stupid)
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 10 Nov 2007 15:49:57 +0000
parents 8fe22cff1779
children abbf74f4732b
line wrap: on
line diff
--- a/configure.ac	Sat Nov 10 15:41:37 2007 +0000
+++ b/configure.ac	Sat Nov 10 15:49:57 2007 +0000
@@ -2003,9 +2003,12 @@
 if test "x$enable_plugins" = "xyes" ; then
 	AC_DEFINE(PURPLE_PLUGINS, 1, [Define if plugins are enabled.])
 	AM_CONDITIONAL(PLUGINS, true)
+	PLUGINS_DEFINE="#define PURPLE_PLUGINS 1"
 else
 	AM_CONDITIONAL(PLUGINS, false)
+	PLUGINS_DEFINE="#undef PURPLE_PLUGINS"
 fi
+AC_SUBST(PLUGINS_DEFINE)
 
 dnl #######################################################################
 dnl # Check for Cyrus-SASL (for Jabber)
@@ -2272,6 +2275,7 @@
 		   libpurple/protocols/yahoo/Makefile
 		   libpurple/protocols/zephyr/Makefile
 		   libpurple/tests/Makefile
+		   libpurple/purple.h
 		   libpurple/version.h
 		   share/Makefile
 		   share/sounds/Makefile