diff configure.ac @ 3411:5df423e0bca8

[gaim-migrate @ 3430] This hopefully adds automake 1.6 support to gaim. I have not tested it, though it came from a guy who uses 1.6, so I'd hope it works. It doesn't break 1.4. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 18 Aug 2002 19:32:05 +0000
parents ba6d0856c8e4
children 59589bb7ce1e
line wrap: on
line diff
--- a/configure.ac	Sun Aug 18 18:28:48 2002 +0000
+++ b/configure.ac	Sun Aug 18 19:32:05 2002 +0000
@@ -151,10 +151,11 @@
 		fi
 	fi
 fi
+		
+GNOME_INIT_HOOK([], nofail, applets)
 
 if test "x$enable_gnome" = "xyes" ; then
 	if test "x$enable_panel" = "xyes" ; then
-		GNOME_INIT(applets)
 		GNOME_X_CHECKS
 		CFLAGS="$CFLAGS $GNOME_INCLUDEDIR"
 		AC_DEFINE(USE_APPLET)
@@ -361,6 +362,7 @@
 	AC_DEFINE(GAIM_PLUGINS)
 	AM_CONDITIONAL(PLUGINS, test "x$enable_plugins" = "xyes")
 else
+	AM_CONDITIONAL(PLUGINS, false)
 	enable_plugins=no
 	enable_prpls=no
 fi
@@ -368,6 +370,7 @@
 if test "x$enable_prpls" = "xyes" ; then
 	AM_CONDITIONAL(PRPLS, test "x$enable_plugins" = "xyes")
 else
+	AM_CONDITIONAL(PRPLS, false)
 	enable_prpls=no
 fi