diff configure.ac @ 9095:61b33ac58669

[gaim-migrate @ 9872] Evolution bumps the version just before release, and libebook is part of evolution-data-server, so we can't check what version we're using to determine if we're calling the new libebook API or not. This should work around that. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Thu, 27 May 2004 18:43:16 +0000
parents c307cf4c84d2
children 6a17b7e2e3b2
line wrap: on
line diff
--- a/configure.ac	Thu May 27 14:51:38 2004 +0000
+++ b/configure.ac	Thu May 27 18:43:16 2004 +0000
@@ -312,6 +312,15 @@
 	AC_SUBST(EVOLUTION_ADDRESSBOOK_CFLAGS)
 	AC_SUBST(EVOLUTION_ADDRESSBOOK_LIBS)
 
+	dnl This is necessary, because Evolution bumps the version just before
+	dnl release, and they broke the API in the current evolution-data-server
+	dnl release (0.0.93). Version checks won't work until 0.0.94, so we'll
+	dnl do this for now. Remove in a couple versions!
+	AC_CHECK_LIB(ebook, e_book_new_system_addressbook,
+	[
+		AC_DEFINE(LIBEBOOK_NEW_API, 1, [new API in libebook 0.0.94cvs])
+	], , $EVOLUTION_ADDRESSBOOK_LIBS)
+
 	dnl This can be removed in a few releases of Evolution, especially when
 	dnl it goes stable!
 	AC_MSG_CHECKING([libebook version])