diff configure.ac @ 23577:62e2869e8e3d

MSNP15 is here! Hopefully I didn't break anything. Sorry for the ton of mail here. Fixes #3264. Fixes #3939. Fixes #4332. Fixes #4339. Fixes #4875 Fixes #4877. Fixes #5379. Fixes #5545. Fixes #5984. Fixes #6210. Fixes #6257. Fixes #5212, I hope. Somewhere or other, this also fixes #4876.
author Elliott Sales de Andrade <qulogic@pidgin.im>
date Sun, 13 Jul 2008 07:14:37 +0000
parents 9ad75be23c93
children 6083c36f68d6 e23b447aa5ca 57727a140609
line wrap: on
line diff
--- a/configure.ac	Sun Jul 13 05:20:46 2008 +0000
+++ b/configure.ac	Sun Jul 13 07:14:37 2008 +0000
@@ -977,8 +977,8 @@
 AC_SUBST(GADU_LIBS)
 AC_SUBST(GADU_CFLAGS)
 
-# change the next line to make MSNP14 the default (s/enable/disable/; s/no/yes/;)
-AC_ARG_ENABLE(msnp14,[AC_HELP_STRING([--enable-msnp14], [Enable the newer MSNP14 protocol (unsupported)])],,enable_msnp14=no)
+# change the next line to not make MSNP15 the default (s/disable/enable/; s/yes/no/;)
+AC_ARG_ENABLE(msnp15,[AC_HELP_STRING([--disable-msnp15], [Disable the newer MSNP15 protocol])],enable_msnp15=$enableval,enable_msnp15=yes)
 
 AC_ARG_ENABLE(distrib,,,enable_distrib=no)
 AM_CONDITIONAL(DISTRIB, test "x$enable_distrib" = "xyes")
@@ -997,7 +997,7 @@
 if test "x$avahiincludes" != "xyes" -o "x$avahilibs" != "xyes"; then
 	STATIC_PRPLS=`echo $STATIC_PRPLS | $sedpath 's/bonjour//'`
 fi
-if test "x$enable_msnp14" != "xyes" ; then
+if test "x$enable_msnp15" != "xyes" ; then
 	STATIC_PRPLS=`echo $STATIC_PRPLS | $sedpath 's/msn/msnp9/'`
 fi
 if test "x$silcincludes" != "xyes" -o "x$silcclient" != "xyes"; then
@@ -1084,7 +1084,7 @@
 if test "x$avahiincludes" != "xyes" -o "x$avahilibs" != "xyes"; then
 	DYNAMIC_PRPLS=`echo $DYNAMIC_PRPLS | $sedpath 's/bonjour//'`
 fi
-if test "x$enable_msnp14" != "xyes" ; then
+if test "x$enable_msnp15" != "xyes" ; then
 	DYNAMIC_PRPLS=`echo $DYNAMIC_PRPLS | $sedpath 's/msn/msnp9/'`
 fi
 if test "x$silcincludes" != "xyes" -o "x$silcclient" != "xyes"; then