diff Makefile.am @ 78:66c5a24b62ec

[gaim-migrate @ 88] Touch-ups with the install for applet. Rather than all that extra stuff at the end of ./configure, all you need now is --enable-gnome. ./configure will figure out where gnome-config is and use that to determine where things should be installed. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Fri, 31 Mar 2000 20:22:12 +0000
parents b1d7336cba85
children 595c26ef5527
line wrap: on
line diff
--- a/Makefile.am	Fri Mar 31 20:21:08 2000 +0000
+++ b/Makefile.am	Fri Mar 31 20:22:12 2000 +0000
@@ -4,16 +4,19 @@
 
 if GNOMEAPPLET
 
+gnomesysconf = `@GNOME_CONFIG@ --sysconfdir`
+gnomedata    = `@GNOME_CONFIG@ --datadir`
+
 gaim_GNORBA = gaim_applet.gnorba
-gaimgnorbadir  = $(sysconfdir)/CORBA/servers
+gaimgnorbadir  = $(gnomesysconf)/CORBA/servers
 gaimgnorba_DATA = $(gaim_GNORBA)
 
 gaim_DESKTOP = gaim_applet.desktop
-gaimdesktopdir = $(datadir)/applets/Network
+gaimdesktopdir = $(gnomedata)/applets/Network
 gaimdesktop_DATA = $(gaim_DESKTOP)
 
 gaim_SOUND = gaim_applet.soundlist
-gaimsounddir = $(sysconfdir)/sound/events
+gaimsounddir = $(gnomesysconf)/sound/events
 gaimsound_DATA = $(gaim_SOUND)
 
 endif