diff console/libgnt/Makefile.am @ 15159:68385f5bbd61

[gaim-migrate @ 17944] Generate the marshal-things during make when necessary. Allow specifying the hash-functions for a GntTree. committer: Tailor Script <tailor@pidgin.im>
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sun, 10 Dec 2006 09:26:44 +0000
parents be2feab10c71
children 7ad1e078ab55
line wrap: on
line diff
--- a/console/libgnt/Makefile.am	Sun Dec 10 09:09:39 2006 +0000
+++ b/console/libgnt/Makefile.am	Sun Dec 10 09:26:44 2006 +0000
@@ -52,6 +52,16 @@
 	gntwm.h \
 	gnt.h
 
+CLEANFILES = \
+	gntmarshal.h \
+	gntmarshal.c
+
+gntmarshal.c: genmarshal
+	cat genmarshal | glib-genmarshal --prefix=gnt_closure_marshal --body > $@
+
+gntmarshal.h: genmarshal
+	cat genmarshal | glib-genmarshal --prefix=gnt_closure_marshal --header > $@
+
 libgnt_laincludedir=$(includedir)/gnt
 libgnt_lainclude_HEADERS = \
 	$(libgnt_la_headers)