diff configure.ac @ 15539:7ae72b7c02b1

sf patch #1640011, from Celso Pinto Patch for gaim.spec that fixes dependencies on SUSE Add line breaks to Evan's NEWS entry sf patch #1639901, from Saleem Abdulrasool Fix the build failure of the Mono example dlls due to the Mono API change Show "(experimental)" next to the enable-mono option when calling "./configure --help" sf patch #1644019, from good ol' Ka-Hing Cheung "fix compiling on gtk 2.4. xmppconsole.c is the culprit. gtk_combo_box_get_active_text is defined in gtk 2.6 but not 2.4." Sun apparently doesn't like when void functions return the return value from another void function. For example: void func1(void) { printf("hi"); } void func2(void) { return func1(); /* this line causes a warning */ }
author Mark Doliner <mark@kingant.net>
date Sun, 04 Feb 2007 08:46:24 +0000
parents e9c12873fae0
children bcdf8880564b 442128853bdb
line wrap: on
line diff
--- a/configure.ac	Sun Feb 04 08:45:07 2007 +0000
+++ b/configure.ac	Sun Feb 04 08:46:24 2007 +0000
@@ -1026,7 +1026,7 @@
 dnl #######################################################################
 dnl # Check for Mono support
 dnl #######################################################################
-AC_ARG_ENABLE(mono, [AC_HELP_STRING([--enable-mono], [compile with Mono runtime support])], , enable_mono=no)
+AC_ARG_ENABLE(mono, [AC_HELP_STRING([--enable-mono], [compile with Mono runtime support (experimental)])], , enable_mono=no)
 if test x"$enable_mono" = x"yes" ; then
 	AC_MSG_CHECKING(for Mono compile flags)
 	MONO_CFLAGS=`pkg-config --cflags mono 2> /dev/null`