diff configure.in @ 981:7e231bc0018a

[gaim-migrate @ 991] I think I need a Pepsi. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Fri, 13 Oct 2000 07:24:40 +0000
parents 4989c959f5b1
children 3dbc2cd326e2
line wrap: on
line diff
--- a/configure.in	Thu Oct 12 18:59:36 2000 +0000
+++ b/configure.in	Fri Oct 13 07:24:40 2000 +0000
@@ -100,8 +100,15 @@
 
 CFLAGS="$CFLAGS $GTK_CFLAGS"
 
+dnl Even more X-Chat code
 if test "$enable_plugins" = yes ; then
-	AC_DEFINE(GAIM_PLUGINS)
+	AC_CHECK_FUNCS(dlopen, have_dl=yes)
+	if test "$have_dl" = yes; then
+		AC_CHECK_FUNCS(dlerror)
+		AC_DEFINE(GAIM_PLUGINS)
+	else
+		enable_plugins=no
+	fi
 fi
 
 dnl This was taken straight from X-Chat.
@@ -145,7 +152,7 @@
 		AC_DEFINE(ESD_SOUND)
                 LDADD="$LDADD $ESD_LIBS"
 	else
-		enable_esd = no
+		enable_esd=no
         fi
 fi
 
@@ -158,7 +165,6 @@
 AC_SUBST(CFLAGS)
 AC_SUBST(LDADD)
 AC_SUBST(LIBS)
-AC_SUBST(LIBFAIM_DO)
 
 AC_OUTPUT([Makefile
 	   src/Makefile