diff configure.ac @ 13741:889ad72bc16e

[gaim-migrate @ 16152] When --enable-debug is used, set --enable-fatal-asserts as well committer: Tailor Script <tailor@pidgin.im>
author Mark Doliner <mark@kingant.net>
date Mon, 08 May 2006 02:26:40 +0000
parents 760528340ee3
children ae1849182c8f
line wrap: on
line diff
--- a/configure.ac	Mon May 08 02:09:44 2006 +0000
+++ b/configure.ac	Mon May 08 02:26:40 2006 +0000
@@ -75,11 +75,11 @@
 ])
 
 dnl Check for inet_aton
-AC_CHECK_FUNC(inet_aton, , [AC_CHECK_LIB(resolv, inet_aton, , 
+AC_CHECK_FUNC(inet_aton, , [AC_CHECK_LIB(resolv, inet_aton, ,
 				         [AC_ERROR(inet_aton not found)])])
 AC_CHECK_LIB(resolv, __res_query)
 AC_CHECK_LIB(nsl, gethostent)
-AC_CHECK_FUNC(socket, , 
+AC_CHECK_FUNC(socket, ,
               [AC_CHECK_LIB(socket, socket, , [AC_ERROR([socket not found])])])
 dnl If all goes well, by this point the previous two checks will have
 dnl pulled in -lsocket and -lnsl if we need them.
@@ -130,12 +130,12 @@
 {
 	char buf[6];
 	time_t t = time(NULL);
-	
+
 	if (strftime(buf, sizeof(buf), "%z", localtime(&t)) != 5)
 		return 1;
-	
+
 	fprintf(stderr, "strftime(\"%%z\") yields: \"%s\"\n", buf);
-	
+
 	return !((buf[0] == '-' || buf[0] == '+') &&
 	         (buf[1] >= '0' && buf[1] <= '9') &&
 	         (buf[2] >= '0' && buf[2] <= '9') &&
@@ -508,6 +508,7 @@
 
 if test "x$enable_debug" = "xyes" ; then
 	AC_DEFINE(DEBUG, 1, [Define if debugging is enabled.])
+	enable_fatal_asserts="yes"
 fi
 
 if test "x$enable_fatal_asserts" = "xyes" ; then