diff configure.ac @ 5449:9442e8d0b21d

[gaim-migrate @ 5836] Decklin Foster writes: "this makes --enable-static-prpls compile again. i'm so lazy. it's only been what, well over a week since the new plugin api broke this? :) i'm not sure if everything here is "correct" but i'm sure someone can look over it. mainly, because i made _load return TRUE all the time, for the sake of consistency/completeness i changed the other applicable functions to do so as well. my feeling is, the only time these things are going to be called in the static case is from static_proto_init (since there's no plugin UI or whatever) and therefore they always "succeed". oh, yeah, and someone please test it *without* static prpls turned on. like i said, i'm lazy. :)" it works for me with no static prpls. committer: Tailor Script <tailor@pidgin.im>
author Luke Schierer <lschiere@pidgin.im>
date Mon, 19 May 2003 17:27:03 +0000
parents 73bde657e212
children b6ef2b1cb70b
line wrap: on
line diff
--- a/configure.ac	Mon May 19 16:00:24 2003 +0000
+++ b/configure.ac	Mon May 19 17:27:03 2003 +0000
@@ -94,8 +94,8 @@
 load_proto=
 for i in $STATIC_PRPLS ; do
 	STATIC_LINK_LIBS="$STATIC_LINK_LIBS protocols/$i/lib$i.a"
-	extern_init="$extern_init extern void ${i}_init(struct prpl *);"
-	load_proto="$load_proto load_protocol(${i}_init);"
+	extern_init="$extern_init extern gboolean gaim_init_${i}_plugin();"
+	load_proto="$load_proto gaim_init_${i}_plugin();"
 	case $i in
 		gg) static_gg=yes ;;
 		irc) static_irc=yes ;;