diff configure.ac @ 14396:9e9699792bb9

[gaim-migrate @ 17104] Add option in gntgf to set the URGENT hint for the terminal's window (in X). Unescape the status-string in the statusbox. committer: Tailor Script <tailor@pidgin.im>
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Fri, 01 Sep 2006 02:07:23 +0000
parents d72cbd259357
children eeca8be382a5
line wrap: on
line diff
--- a/configure.ac	Thu Aug 31 22:04:16 2006 +0000
+++ b/configure.ac	Fri Sep 01 02:07:23 2006 +0000
@@ -680,6 +680,11 @@
 	x_incpath_add="-I$x_includes"
 fi
 
+PKG_CHECK_MODULES(X11, x11, 
+	[AC_DEFINE(HAVE_X11, 1, [Define to 1 if you have X11])], [AC_MSG_RESULT(no)])
+AC_SUBST(X11_LIBS)
+AC_SUBST(X11_CFLAGS)
+
 dnl #######################################################################
 dnl # Check for DBUS libraries
 dnl #######################################################################
@@ -823,21 +828,6 @@
 
 if test "x$enable_gtk" = "xyes"; then
 
-AC_PATH_XTRA
-# We can't assume that $x_libraries will be set, because autoconf does not
-# set it in the case when the X libraries are in a standard place.
-# Ditto for $x_includes
-if test X"$x_libraries" = X"" || test X"$x_libraries" = XNONE; then
-	x_libpath_add=
-else
-	x_libpath_add="-L$x_libraries"
-fi
-if test X"$x_includes" = X"" || test X"$x_includes" = XNONE; then
-	x_incpath_add=
-else
-	x_incpath_add="-I$x_includes"
-fi
-
 dnl #######################################################################
 dnl # Check for startup notification
 dnl #######################################################################