diff src/protocols/novell/Makefile.am @ 8675:9ee2542d1104

[gaim-migrate @ 9428] A GroupWise plugin from Novell. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Sat, 17 Apr 2004 13:55:28 +0000
parents
children 76935eb1bd40
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/protocols/novell/Makefile.am	Sat Apr 17 13:55:28 2004 +0000
@@ -0,0 +1,53 @@
+EXTRA_DIST = \
+		Makefile.mingw
+
+pkgdir = $(libdir)/gaim
+
+NOVELLSOURCES = \
+		nmfield.h \
+		nmfield.c \
+		nmconn.h \
+		nmconn.c \
+		nmconference.h \
+		nmconference.c \
+		nmcontact.h \
+		nmcontact.c \
+		nmevent.h \
+		nmevent.c \
+		nmmessage.h \
+		nmmessage.c \
+		nmrequest.h \
+		nmrequest.c \
+		nmuser.h \
+		nmuser.c \
+		nmuserrecord.h \
+		nmuserrecord.c \
+		novell.c
+
+AM_CFLAGS = $(st)
+
+libnovell_la_LDFLAGS = -module -avoid-version
+
+if STATIC_NOVELL
+
+st = -DSTATIC
+noinst_LIBRARIES = libnovell.a
+pkg_LTLIBRARIES =
+
+libnovell_a_SOURCES = $(NOVELLSOURCES)
+libnovell_a_CFLAGS = $(AM_CFLAGS)
+
+else
+
+st =
+pkg_LTLIBRARIES = libnovell.la
+noinst_LIBRARIES =
+
+libnovell_la_SOURCES = $(NOVELLSOURCES)
+
+endif
+
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src \
+	$(DEBUG_CFLAGS) \
+	$(GLIB_CFLAGS)