diff plugins/jabber/Makefile.am @ 1347:afa63ac2fd84

[gaim-migrate @ 1357] jabber for those not fortunate enough to have libjabber and libxode on their systems committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Thu, 21 Dec 2000 14:54:13 +0000
parents 338b8ac6bdab
children
line wrap: on
line diff
--- a/plugins/jabber/Makefile.am	Thu Dec 21 13:56:59 2000 +0000
+++ b/plugins/jabber/Makefile.am	Thu Dec 21 14:54:13 2000 +0000
@@ -1,7 +1,46 @@
 CFLAGS += -I\$(top_srcdir)/src
-LIBS += $(GTK_LIBS) -lxode -ljabber
+LIBS += $(GTK_LIBS)
 
 pkgdir = $(libdir)/gaim
 pkg_LTLIBRARIES = libjabber.la
 
-libjabber_la_SOURCES = jabber.c
+EXTRA_DIST = xmltok_impl.c xmltok_ns.c
+
+libjabber_la_SOURCES = \
+			asciitab.h \
+			expat.c \
+			genhash.c \
+			hashtable.c \
+			hashtable.h \
+			iasciitab.h \
+			latin1tab.h \
+			libxode.h \
+			nametab.h \
+			pool.c \
+			sha.c \
+			snprintf.c \
+			socket.c \
+			str.c \
+			utf8tab.h \
+			xmldef.h \
+			xmlnode.c \
+			xmlparse.c \
+			xmlparse.h \
+			xmlrole.c \
+			xmlrole.h \
+			xmltok.c \
+			xmltok.h \
+			xmltok_impl.h \
+			xstream.c \
+			\
+			jabber.h \
+			jconn.c \
+			jid.c \
+			jpacket.c \
+			jutil.c \
+			log.c \
+			log.h \
+			pproxy.c \
+			rate.c \
+			\
+			jabber.c