diff Makefile.am @ 24305:b31d2ca01b7a

applied changes from 84461a44ffa2c1e7ab026455c5463a9763f64a9d through 767e27764fc328b2768ea7715850c1d81899c059
author Richard Laager <rlaager@wiktel.com>
date Sun, 02 Nov 2008 22:12:33 +0000
parents cb0aa91430bb
children e5efa83aa6d2 d1a4088528ce
line wrap: on
line diff
--- a/Makefile.am	Sat Nov 01 19:08:55 2008 +0000
+++ b/Makefile.am	Sun Nov 02 22:12:33 2008 +0000
@@ -30,7 +30,12 @@
 distcheck-hook: libpurple/plugins/perl/common/Purple.pm pidgin/plugins/perl/common/Pidgin.pm
 #	cp libpurple/plugins/perl/common/Gaim.pm $(distdir)/libpurple/plugins/perl/common
 
-version-check:
+commit-check:
+	(cd po ; intltool-update -m 2>&1 | grep -v '^mismatched quotes.*\.py$$' | sed "s|current directory|po directory|" | grep . ; if [ $$? = 0 ] ; then exit 1 ; else exit 0 ; fi)
+	LC_ALL=C sort -c -t/ -u po/POTFILES.in
+	LC_ALL=C sort -c -t/ -u po/POTFILES.skip
+
+version-check: commit-check
 # We don't want to release development versions.
 	test x`echo $(PACKAGE_VERSION) | grep dev` = x