diff configure.ac @ 30373:b3377040edc1

Build fixes on OpenSolaris. Closes #11841. committer: Paul Aurich <paul@darkrain42.org>
author brian.lu@sun.com
date Sun, 16 May 2010 15:57:51 +0000
parents 4b3bad9ca939
children 2a19f7385ba5 44ec2e7c2488 95d2b6fc228a
line wrap: on
line diff
--- a/configure.ac	Sun May 16 15:50:23 2010 +0000
+++ b/configure.ac	Sun May 16 15:57:51 2010 +0000
@@ -115,6 +115,9 @@
 PKG_PROG_PKG_CONFIG
 AC_FUNC_ALLOCA
 
+dnl Check for Sun compiler
+AC_CHECK_DECL([__SUNPRO_C], [SUNCC="yes"], [SUNCC="no"])
+
 dnl Checks for header files.
 AC_HEADER_STDC
 AC_HEADER_SYS_WAIT
@@ -1337,6 +1340,10 @@
 	DEBUG_CFLAGS="-Wall $DEBUG_CFLAGS"
 	CFLAGS="-g $CFLAGS"
 fi
+
+if test "x$SUNCC" = "xyes"; then
+        CFLAGS="-features=extensions" 
+fi
 AC_SUBST(CFLAGS)
 
 AC_PATH_PROG(pidginpath, pidgin)