diff pidgin/plugins/Makefile.am @ 28403:b9e28b2a119b

Don't compile the VV Config plugin unless VV is actually enabled
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 22 Aug 2009 04:44:11 +0000
parents 33e8d40ae6ec
children 7193a541ca83 1ca2df744414
line wrap: on
line diff
--- a/pidgin/plugins/Makefile.am	Sat Aug 22 04:03:09 2009 +0000
+++ b/pidgin/plugins/Makefile.am	Sat Aug 22 04:44:11 2009 +0000
@@ -67,9 +67,12 @@
 	themeedit.la         \
 	timestamp.la        \
 	timestamp_format.la \
-	vvconfig.la         \
 	xmppconsole.la
 
+if USE_VV
+plugin_LTLIBRARIES +=	vvconfig.la
+endif
+
 noinst_LTLIBRARIES = \
 	contact_priority.la \
 	gtk_signals_test.la
@@ -109,7 +112,7 @@
 themeedit_la_LIBADD         = $(GTK_LIBS)
 timestamp_la_LIBADD         = $(GTK_LIBS)
 timestamp_format_la_LIBADD  = $(GTK_LIBS)
-vvconfig_la_LIBADD          = $(GTK_LIBS)
+vvconfig_la_LIBADD          = $(GTK_LIBS) $(GSTREAMER_LIBS)
 xmppconsole_la_LIBADD       = $(GTK_LIBS)
 
 endif # PLUGINS