diff configure.ac @ 15041:ba149ceb20b7

[gaim-migrate @ 17823] baby steps: 4 unit tests for libgaim to run these, you'll need check (http://check.sf.net/) 0.9.4 or later installed they run when you run 'make check' committer: Tailor Script <tailor@pidgin.im>
author Nathan Walp <nwalp@pidgin.im>
date Sun, 26 Nov 2006 22:03:23 +0000
parents 37588c827c27
children 902f3621aa13
line wrap: on
line diff
--- a/configure.ac	Sun Nov 26 20:45:29 2006 +0000
+++ b/configure.ac	Sun Nov 26 22:03:23 2006 +0000
@@ -1807,6 +1807,14 @@
 fi
 
 dnl #######################################################################
+dnl # Check for check
+dnl #######################################################################
+PKG_CHECK_MODULES(CHECK, check >= 0.9.4, have_check=yes, have_check=no)
+AM_CONDITIONAL(HAVE_CHECK, test "x$have_check" = "xyes")
+AC_SUBST(CHECK_CFLAGS)
+AC_SUBST(CHECK_LIBS)
+
+dnl #######################################################################
 dnl # Check for Doxygen and dot (part of GraphViz)
 dnl #######################################################################
 AC_ARG_ENABLE(doxygen,
@@ -1906,6 +1914,7 @@
 		   libgaim/protocols/toc/Makefile
 		   libgaim/protocols/yahoo/Makefile
 		   libgaim/protocols/zephyr/Makefile
+		   libgaim/tests/Makefile
 		   console/Makefile
 		   console/libgnt/Makefile
 		   console/libgnt/gnt.pc