diff configure.in @ 1418:baef6e30f3a7

[gaim-migrate @ 1428] patch from decklin to not build prpls/plugins if disabled committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Sat, 20 Jan 2001 23:56:25 +0000
parents f8f9c68960ea
children 3d1c4e5f375b
line wrap: on
line diff
--- a/configure.in	Sat Jan 20 23:42:11 2001 +0000
+++ b/configure.in	Sat Jan 20 23:56:25 2001 +0000
@@ -41,6 +41,7 @@
 AC_ARG_ENABLE(distrib,,,enable_distrib=no)
 AM_CONDITIONAL(DISTRIB, test "x$enable_distrib" = "xyes")
 AC_ARG_ENABLE(multi,   [  --disable-multi         disable multiple connections],,enable_multi=yes)
+AC_ARG_ENABLE(prpls,   [  --disable-prpls         don't build protocol plugins],,enable_prpls=yes)
 AC_ARG_ENABLE(gnome,   [  --disable-gnome         compile without Gnome bits],,enable_gnome=yes)
 AC_ARG_ENABLE(panel,   [  --enable-panel          compile as a GNOME applet],,enable_panel=$enable_distrib)
 AM_CONDITIONAL(GNOMEAPPLET, test "x$enable_panel" = "xyes")
@@ -180,9 +181,18 @@
 
 if test "x$enable_multi" != "xyes" ; then
 	AC_DEFINE(NO_MULTI)
+	enable_multi=no
 fi
 
-if test "x$enable_plugins" = xyes ; then
+if test "x$enable_plugins" = "xyes" ; then
+	AC_DEFINE(GAIM_PLUGINS)
+	AM_CONDITIONAL(PLUGINS, test "x$enable_plugins" = "xyes")
+else
+	enable_plugins=no
+	enable_prpls=no
+fi
+
+if test "x$enable_prpls" = "xyes" ; then
 	dnl checks for icqlib
 	AC_CHECK_HEADERS(asm/byteorder.h byteswap.h endian.h machine/endian.h arpa/nameser_compat.h)
 	AC_CHECK_FUNCS(bswap_32 bswap_16)
@@ -192,8 +202,9 @@
 	AC_CHECK_FUNCS(snprintf connect)
 	AC_CHECK_LIB(nsl, gethostent)
 
-	AC_DEFINE(GAIM_PLUGINS)
-	AM_CONDITIONAL(PLUGINS, test "x$enable_plugins" = "xyes")
+	AM_CONDITIONAL(PRPLS, test "x$enable_plugins" = "xyes")
+else
+	enable_prpls=no
 fi
 
 AC_OUTPUT([Makefile
@@ -217,6 +228,9 @@
 echo $PACKAGE $VERSION
 
 echo
+echo Allow Multiple Connections. : $enable_multi
+echo Build Protocol Plugins..... : $enable_prpls
+echo
 echo Build with GNOME bits...... : $enable_gnome
 echo Build as GNOME applet...... : $enable_panel
 echo