diff configure.ac @ 20879:bc1e6ea98445

Try to fix msgfmt detection *again*. If this doesn't work, we'll probably have to start writing our own macros for this junk, which I greatly desire to NOT do.
author Ethan Blanton <elb@pidgin.im>
date Thu, 11 Oct 2007 17:29:39 +0000
parents 71c7d0222a33
children f34539eb7a61 d604027959a5
line wrap: on
line diff
--- a/configure.ac	Wed Oct 10 20:29:16 2007 +0000
+++ b/configure.ac	Thu Oct 11 17:29:39 2007 +0000
@@ -142,13 +142,21 @@
 dnl If we don't have msgfmt, then po/ is going to fail -- ensure that
 dnl AM_GLIB_GNU_GETTEXT found it.
 
-if test x$MSGFMT = xno
+if test x$MSGFMT = xno -o x$MSGFMT$GMSGFMT = x
 then
 	AC_ERROR([
 
 The msgfmt command is required to build libpurple.  If it is installed
 on your system, ensure that it is in your path.  If it is not, install
 GNU gettext to continue.
+
+If you have msgfmt installed, but for some reason this error message
+is still displayed, you have encountered what appears to be a bug in
+third-party configure macros.  Try setting the MSGFMT environment
+variable to the absolute path to your msgfmt binary and trying
+configure again, like this:
+
+MSGFMT=/path/to/msgfmt ./configure ...
 ])
 fi