diff plugins/mono/api/Makefile.am @ 11882:c0e0fcd75926

[gaim-migrate @ 14173] "make distcheck" fixes for the mono plugin loader (aka. Makefile rewrites) committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 29 Oct 2005 02:01:55 +0000
parents d8f002812186
children 67fbd2ff4c4e
line wrap: on
line diff
--- a/plugins/mono/api/Makefile.am	Sat Oct 29 01:28:19 2005 +0000
+++ b/plugins/mono/api/Makefile.am	Sat Oct 29 02:01:55 2005 +0000
@@ -1,4 +1,5 @@
-MONOSOURCES = \
+monodir=$(libdir)/gaim
+mono_sources = \
 	GaimPlugin.cs \
 	Debug.cs \
 	BuddyList.cs \
@@ -6,17 +7,16 @@
 	Signal.cs \
 	Event.cs
 
-TARGET=GaimAPI.dll
+EXTRA_DIST = $(mono_sources)
 
-all: $(TARGET)
+mono_SCRIPTS = GaimAPI.dll
 
-$(TARGET): $(MONOSOURCES)
-	mcs -t:library -out:$(TARGET) $(MONOSOURCES)
+mono_build_sources = $(addprefix $(srcdir)/, $(mono_sources))
 
-.PHONY: install clean
+all: $(mono_SCRIPTS)
 
-install: $(TARGET)
-	$(INSTALL) -m 644 $(TARGET) $(libdir)/gaim
-	
-clean:
-	rm -rf $(TARGET)
+$(mono_SCRIPTS): $(mono_build_sources)
+	mcs -t:library -out:$(mono_SCRIPTS) $(mono_build_sources)
+
+clean-local:
+	rm -rf $(mono_SCRIPTS)