diff console/Makefile.am @ 14228:c18bdf510325

[gaim-migrate @ 16910] Fix autogen.sh to run glib-gettextize Fix CFLAGS when gstreamer is not installed Make things work with gtk < 2.6, in part by borrowing some code from gdk Don't link gntgaim with gstreamer, xss or sm committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 20 Aug 2006 17:49:58 +0000
parents f306918687a4
children 4c82afb76534
line wrap: on
line diff
--- a/console/Makefile.am	Sun Aug 20 17:34:21 2006 +0000
+++ b/console/Makefile.am	Sun Aug 20 17:49:58 2006 +0000
@@ -35,18 +35,16 @@
 gntgaiminclude_HEADERS = \
 	$(gntgaim_headers)
 
-gntgaim_DEPENDENCIES = @LIBOBJS@ $(STATIC_LINK_LIBS) $(MS_LIBS)
+gntgaim_DEPENDENCIES = @LIBOBJS@ $(STATIC_LINK_LIBS)
 gntgaim_LDFLAGS = -export-dynamic
 gntgaim_LDADD = \
 	@LIBOBJS@ \
 	$(DBUS_LIBS) \
-	$(GSTREAMER_LIBS) \
 	$(STATIC_LINK_LIBS) \
-	$(XSS_LIBS) \
-	$(SM_LIBS) \
 	$(INTLLIBS) \
 	$(GLIB_LIBS) \
 	$(LIBXML_LIBS) \
+	$(GNT_LIBS) \
 	-L./libgnt/ -lgnt \
 	-L$(top_srcdir)/libgaim -lgaim
 
@@ -59,7 +57,6 @@
 	-DSYSCONFDIR=\"$(sysconfdir)\" \
 	-I$(top_srcdir)/libgaim/ \
 	-I ./libgnt/ \
-	$(GSTREAMER_CFLAGS) \
 	$(DEBUG_CFLAGS) \
 	$(GLIB_CFLAGS) \
 	$(DBUS_CFLAGS) \