diff configure.ac @ 22007:c38d72677c8a

Probe for -Wstrict-prototypes to get some more warnings. I then cleaned up the existing warnings. I removed a handful of dead code and cleaned up a couple of things that I stumbled across.
author Richard Laager <rlaager@wiktel.com>
date Thu, 03 Jan 2008 04:57:40 +0000
parents d230e1cfff62
children 5c472f6aa039
line wrap: on
line diff
--- a/configure.ac	Wed Jan 02 22:15:06 2008 +0000
+++ b/configure.ac	Thu Jan 03 04:57:40 2008 +0000
@@ -978,7 +978,7 @@
 AM_CONDITIONAL(STATIC_YAHOO, test "x$static_yahoo" = "xyes")
 AM_CONDITIONAL(STATIC_ZEPHYR, test "x$static_zephyr" = "xyes")
 AC_SUBST(STATIC_LINK_LIBS)
-AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init static void static_proto_init() { $load_proto },
+AC_DEFINE_UNQUOTED(STATIC_PROTO_INIT, $extern_init static void static_proto_init(void) { $load_proto },
 	[Loads static protocol plugin module initialization functions.])
 
 AC_ARG_WITH(dynamic_prpls, [AC_HELP_STRING([--with-dynamic-prpls], [specify which protocols to build dynamically])], [DYNAMIC_PRPLS=`echo $withval | $sedpath 's/,/ /g'`])
@@ -1086,6 +1086,7 @@
 			"-Wmissing-prototypes" \
 			"-Wnested-externs" \
 			"-Wpointer-arith" \
+			"-Wstrict-prototypes" \
 			"-Wundef" \
 	; do
 		orig_CFLAGS="$CFLAGS"