diff configure.ac @ 15885:c6e563dfaa7a

More s/gaim/pidgin/ and s/gaim/purple/ and make the RPM spec file work a bit
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 24 Mar 2007 17:51:05 +0000
parents b6983e807711
children 6f04fe174f40
line wrap: on
line diff
--- a/configure.ac	Sat Mar 24 17:07:17 2007 +0000
+++ b/configure.ac	Sat Mar 24 17:51:05 2007 +0000
@@ -1,5 +1,5 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_INIT([pidgin], [2.0.0beta7devel], [gaim-devel@lists.sourceforge.net])
+AC_INIT([pidgin], [2.0.0beta7devel], [devel@pidgin.im])
 AC_CANONICAL_SYSTEM
 AM_CONFIG_HEADER(config.h)
 AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
@@ -700,14 +700,14 @@
 extern_init=
 load_proto=
 for i in $STATIC_PRPLS ; do
-	dnl Ugly special case for "libsilcgaim.a":
+	dnl Ugly special case for "libsilcpurple.a":
 	if test "x$i" = "xsilc"; then
-		STATIC_LINK_LIBS="$STATIC_LINK_LIBS protocols/$i/lib${i}gaim.a"
+		STATIC_LINK_LIBS="$STATIC_LINK_LIBS protocols/$i/lib${i}purple.a"
 	else
 		STATIC_LINK_LIBS="$STATIC_LINK_LIBS protocols/$i/lib$i.a"
 	fi
-	extern_init="$extern_init extern gboolean gaim_init_${i}_plugin();"
-	load_proto="$load_proto gaim_init_${i}_plugin();"
+	extern_init="$extern_init extern gboolean purple_init_${i}_plugin();"
+	load_proto="$load_proto purple_init_${i}_plugin();"
 	case $i in
 		bonjour)	static_bonjour=yes ;;
 		gg)			static_gg=yes ;;
@@ -935,7 +935,7 @@
 dnl it is now accessible through D-Bus.
 
 dnl Python is only required if --enable-dbus is used, and only for
-dnl the build process to generate the code, not for running gaim.
+dnl the build process to generate the code, not for running pidgin.
 dnl This autogenerated code is system-independent, so in principle we
 dnl can generate all of it before shipping.  But I thought adding
 dnl auto-generated stuff to the repository is inelegant.
@@ -1145,7 +1145,7 @@
 
 		AC_ARG_WITH(perl-lib,
 		[AC_HELP_STRING([--with-perl-lib=[site|vendor|DIR]],
-			[specify where to install the Perl libraries for gaim. Default is site.])],
+			[specify where to install the Perl libraries for pidgin. Default is site.])],
 		[
 			if test "x$withval" = xsite; then
 				PERL_MM_PARAMS=""
@@ -1890,7 +1890,7 @@
 AC_ARG_ENABLE(fatal-asserts, [AC_HELP_STRING([--enable-fatal-asserts],
 	[make assertions fatal (useful for debugging)])], , enable_fatal_asserts=no)
 if test "x$enable_fatal_asserts" = "xyes" ; then
-	AC_DEFINE(GAIM_FATAL_ASSERTS, 1, [Define to make assertions fatal (useful for debugging).])
+	AC_DEFINE(PURPLE_FATAL_ASSERTS, 1, [Define to make assertions fatal (useful for debugging).])
 fi
 
 AC_OUTPUT([Makefile
@@ -1903,12 +1903,13 @@
 		   m4macros/Makefile
 		   pidgin/Makefile
 		   pidgin/pidgin.pc
+		   pidgin/pidgin-uninstalled.pc
 		   pidgin/pixmaps/Makefile
 		   pidgin/pixmaps/animations/Makefile
 		   pidgin/pixmaps/animations/16/Makefile
 		   pidgin/pixmaps/buddy_icons/Makefile
 		   pidgin/pixmaps/buddy_icons/qq/Makefile
- 		   pidgin/pixmaps/dialogs/Makefile
+		   pidgin/pixmaps/dialogs/Makefile
 		   pidgin/pixmaps/dialogs/16/Makefile
 		   pidgin/pixmaps/dialogs/16/scalable/Makefile
 		   pidgin/pixmaps/dialogs/64/Makefile
@@ -1919,7 +1920,7 @@
 		   pidgin/pixmaps/emotes/Makefile
 		   pidgin/pixmaps/emotes/default/Makefile
 		   pidgin/pixmaps/emotes/default/22/Makefile
-		   pidgin/pixmaps/emotes/default/22/scalable/Makefile	
+		   pidgin/pixmaps/emotes/default/22/scalable/Makefile
 		   pidgin/pixmaps/emotes/none/Makefile
 		   pidgin/pixmaps/protocols/Makefile
 		   pidgin/pixmaps/protocols/16/Makefile
@@ -1958,6 +1959,7 @@
 		   libpurple/example/Makefile
 		   libpurple/gconf/Makefile
 		   libpurple/purple.pc
+		   libpurple/purple-uninstalled.pc
 		   libpurple/plugins/Makefile
 		   libpurple/plugins/mono/Makefile
 		   libpurple/plugins/mono/api/Makefile
@@ -1989,9 +1991,7 @@
 		   finch/libgnt/wms/Makefile
 		   finch/plugins/Makefile
 		   po/Makefile.in
-		   gaim.pc
-		   gaim-uninstalled.pc
-		   gaim.spec
+		   pidgin.spec
 		  ])
 
 echo
@@ -2030,7 +2030,7 @@
 echo Print debugging messages...... : $enable_debug
 echo Assertions are fatal.......... : $enable_fatal_asserts
 echo
-eval eval echo Gaim will be installed in $bindir.
+eval eval echo Pidgin will be installed in $bindir.
 if test "x$gaimpath" != "x" ; then
 	echo Warning: You have an old copy of gaim at $gaimpath.
 fi