diff libpurple/plugins/mono/Makefile.am @ 16591:ce049678a67b

soname versioning of libpurple. Should help resolve debian bug 421282 All version control is within configure.ac now Adjust the define for purple_version_suffix as appropriate: [devel] - normal development periods [betaN] - for beta releases [] - for releases Follow the instructions in configure.ac to set the version number depending on how the API has changed (ie. following our normal version numbering!) version.h is auto-generated now Added purple_version_check(), purple_major_version, purple_minor_version, & purple_micro_version for run-time version comparisons in addition to the existing compile time macros. libpurple Plugins moved again, this time to: $(libdir)/purple-$PURPLE_MAJOR_VERSION This will allow parallel installations of different major libpurple versions in the future should someone wish to.
author Stu Tomlinson <stu@nosnilmot.com>
date Sat, 28 Apr 2007 16:55:31 +0000
parents 7125eda8fe22
children
line wrap: on
line diff
--- a/libpurple/plugins/mono/Makefile.am	Sat Apr 28 12:58:16 2007 +0000
+++ b/libpurple/plugins/mono/Makefile.am	Sat Apr 28 16:55:31 2007 +0000
@@ -5,7 +5,7 @@
 
 EXTRA_DIST = $(mono_sources)
 
-monodir = $(libdir)/purple
+monodir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 mono_SCRIPTS = MPlugin.dll GetBuddyBack.dll
 mono_build_sources = $(addprefix $(srcdir)/, $(mono_sources))