diff plugins/gaim-remote/Makefile.am @ 5884:d188b000e892

[gaim-migrate @ 6316] There's now a gaim-remote.so (gaim plugin) and a libgaim-remote.so (library for interfacing with an instance of gaim with gaim-remote.so loaded). The gaim-remote tool links to the library, as does the plugin. Now there are far too many things named gaim-remote. The Makefile should also work again. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sun, 15 Jun 2003 07:19:59 +0000
parents 059d95c67cda
children 2e23ccbccdec
line wrap: on
line diff
--- a/plugins/gaim-remote/Makefile.am	Sun Jun 15 06:14:47 2003 +0000
+++ b/plugins/gaim-remote/Makefile.am	Sun Jun 15 07:19:59 2003 +0000
@@ -1,18 +1,28 @@
+grincludedir = $(includedir)/gaim-remote
+
 plugindir = $(libdir)/gaim
 
+lib_LTLIBRARIES = libgaim-remote.la
+
+grinclude_HEADERS = \
+	remote-socket.h \
+	remote.h
+
+libgaim_remote_la_SOURCES = remote-socket.c
+
+
 gaim_remote_la_LDFLAGS = -module -avoid-version
 
 if PLUGINS
 
 plugin_LTLIBRARIES = gaim-remote.la
 
-gaim_remote_la_SOURCES = \
-	remote.c \
-	remote-socket.c \
-	remote-socket.h
+gaim_remote_la_SOURCES = remote.c
+gaim_remote_la_LIBADD = -lgaim-remote
 
 endif
 
+
 INCLUDES = \
 	-I$(top_srcdir)/src \
 	-I$(top_srcdir)/plugins \