diff configure.ac @ 14671:d347b09626ee

[gaim-migrate @ 17417] Tidy the configure output if suitable sqlite3 is not found, and ensure cap is not built when not building gtk gaim committer: Tailor Script <tailor@pidgin.im>
author Stu Tomlinson <stu@nosnilmot.com>
date Sun, 01 Oct 2006 15:16:21 +0000
parents 1e1bcb4a6d82
children 34083fe39891
line wrap: on
line diff
--- a/configure.ac	Sun Oct 01 15:14:05 2006 +0000
+++ b/configure.ac	Sun Oct 01 15:16:21 2006 +0000
@@ -344,15 +344,19 @@
 	dnl # Check for libsqlite3 (for the Contact Availability Prediction plugin)
 	dnl #######################################################################
 	if test "x$enable_cap" = "xyes"; then
-		PKG_CHECK_MODULES(SQLITE3, sqlite3 >= 3.3, , enable_cap="no")
+		PKG_CHECK_MODULES(SQLITE3, sqlite3 >= 3.3,,[
+													AC_MSG_RESULT(no)
+													enable_cap="no"
+													])
 	fi
 
 else # GTK
+	enable_cap=no
+	enable_gevolution=no
+	enable_gtkspell=no
 	enable_screensaver=no
 	enable_sm=no
 	enable_startup_notification=no
-	enable_gtkspell=no
-	enable_gevolution=no
 fi	# GTK
 
 AM_CONDITIONAL(ENABLE_GTK, test "x$enable_gtkui" = "xyes")