diff configure.ac @ 7351:d5ed905a8ccd

[gaim-migrate @ 7942] Improve Tcl detection on systems with Tcl in a nonstandard location. committer: Tailor Script <tailor@pidgin.im>
author Ethan Blanton <elb@pidgin.im>
date Mon, 27 Oct 2003 18:05:24 +0000
parents 09577bf3e062
children 1dbf83536d83
line wrap: on
line diff
--- a/configure.ac	Mon Oct 27 16:11:54 2003 +0000
+++ b/configure.ac	Mon Oct 27 18:05:24 2003 +0000
@@ -766,7 +766,7 @@
 			eval "TCL_LIB_SPEC=\"$TCL_LIB_SPEC\""
 			AC_MSG_CHECKING([for Tcl linkability])
 			oldCPPFLAGS=$CPPFLAGS
-			CPPFLAGS="$CPPFLAGS $TCL_INCLUDE_SPEC"
+			CPPFLAGS="$CPPFLAGS $TCL_INCLUDE_SPEC -I$TCL_PREFIX/include"
 			oldLIBS=$LIBS
 			LIBS="$LIBS $TCL_LIB_SPEC"
 			AC_TRY_LINK([#include <tcl.h>],
@@ -783,7 +783,7 @@
 	AM_CONDITIONAL(USE_TCL, true)
 	TCL_LIBS=$TCL_LIB_SPEC
 	AC_SUBST(TCL_LIBS)
-	TCL_CFLAGS=$TCL_INCLUDE_SPEC
+	TCL_CFLAGS="$TCL_INCLUDE_SPEC -I$TCL_PREFIX/include"
 	if test "x$GCC" = "xyes"; then
 		TCL_CFLAGS="$TCL_CFLAGS -fno-strict-aliasing"
 	fi