diff configure.ac @ 8525:d8dfab355d2c

[gaim-migrate @ 9264] --enable-debug no longer breaks compilation when using gtk 2.4. This was a problem for me personally for a long time, and with the release of gtk 2.4, we're going to see it more without this. It affected gargnome (I think it was garnome?) as well. I added a --disable-deprecated flag for configure that will disable deprecated gtk/glib/pango code. This should suffice, imho. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Tue, 30 Mar 2004 06:00:04 +0000
parents db4a125edd7b
children 5c3542e63997
line wrap: on
line diff
--- a/configure.ac	Tue Mar 30 04:49:53 2004 +0000
+++ b/configure.ac	Tue Mar 30 06:00:04 2004 +0000
@@ -181,6 +181,7 @@
 AC_ARG_WITH(tkconfig,  [  --with-tkconfig=DIR     directory containing tkConfig.sh])
 AC_ARG_ENABLE(gtkspell, [  --disable-gtkspell      compile without GtkSpell automatic spell checking],,enable_gtkspell=yes)
 AC_ARG_ENABLE(debug,   [  --enable-debug          compile with debugging support],,enable_debug=no)
+AC_ARG_ENABLE(deprecated,    [  --disable-deprecated    compile without deprecated API usage],,enable_deprecated=yes)
 AC_ARG_ENABLE(screensaver,   [  --disable-screensaver   compile without X screensaver extension],,enable_xss=yes)
 AC_ARG_ENABLE(sm,      [  --disable-sm            compile without X session management support],,enable_sm=yes)
 AC_ARG_WITH(krb4,      [  --with-krb4=PREFIX      Compile Zephyr plugin with Kerberos 4 support],kerberos="$withval",kerberos="no")
@@ -189,8 +190,11 @@
 AM_CONDITIONAL(EXTERNAL_LIBZEPHYR, test "x$zephyr" != "xno")
 
 if test "$enable_debug" = yes ; then
+	AC_DEFINE(DEBUG, 1, [Define if debugging is enabled.])
+fi
+
+if test "x$enable_deprecated" = no; then
 	DEBUG_CFLAGS="$DEBUG_CFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
-	AC_DEFINE(DEBUG, 1, [Define if debugging is enabled.])
 fi
 
 if test "x$GCC" = "xyes"; then