diff configure.ac @ 21715:dc3b920b27d0

NSS is in the pkg-config package 'microb-engine-nss' on maemo, not 'nss' or 'mozilla-nss'. (microb-engine-nss will only be tried if the other two names are not found.)
author Will Thompson <will.thompson@collabora.co.uk>
date Mon, 03 Dec 2007 14:40:46 +0000
parents d7845234c752
children ca3271a66314
line wrap: on
line diff
--- a/configure.ac	Sat Dec 01 23:42:21 2007 +0000
+++ b/configure.ac	Mon Dec 03 14:40:46 2007 +0000
@@ -1659,16 +1659,24 @@
 			])
 			mozilla_nspr="mozilla-nspr"
 			mozilla_nss="mozilla-nss"
-		else
-			if `$PKG_CONFIG --exists nss`; then
-				PKG_CHECK_MODULES(NSS, nss, [
-					have_nss="yes"
-				], [
-					AC_MSG_RESULT(no)
-				])
-				mozilla_nspr="nspr"
-				mozilla_nss="nss"
-			fi
+		elif `$PKG_CONFIG --exists nss`; then
+			PKG_CHECK_MODULES(NSS, nss, [
+				have_nss="yes"
+			], [
+				AC_MSG_RESULT(no)
+				have_nss="no"
+			])
+			mozilla_nspr="nspr"
+			mozilla_nss="nss"
+		elif `$PKG_CONFIG --exists microb-engine-nss`; then
+			PKG_CHECK_MODULES(NSS, microb-engine-nss, [
+				have_nss="yes"
+			], [
+				AC_MSG_RESULT(no)
+				have_nss="no"
+			])
+			mozilla_nspr="mozilla-nspr"
+			mozilla_nss="microb-engine-nss"
 		fi
 
 		if test "x$have_nss" = "xyes"; then