diff src/Makefile.am @ 7763:dc79649b829d

[gaim-migrate @ 8408] This is an implementation of immutable, reference-counted strings. It is exceedingly trivial, I have no idea why I didn't do this long ago... PLEASE use these anywhere you pass around strings that may be stuck in multiple places; I'm not sure that it will save us too much heap holistically, but it should prevent having to make a hojillion twenty-byte allocations and free them immediately. committer: Tailor Script <tailor@pidgin.im>
author Ethan Blanton <elb@pidgin.im>
date Fri, 05 Dec 2003 16:56:03 +0000
parents 2fb83607becf
children cb400cd78961
line wrap: on
line diff
--- a/src/Makefile.am	Fri Dec 05 16:22:49 2003 +0000
+++ b/src/Makefile.am	Fri Dec 05 16:56:03 2003 +0000
@@ -97,6 +97,8 @@
 	signals.h \
 	status.c \
 	status.h \
+	stringref.c \
+	stringref.h \
 	sound.c \
 	sound.h \
 	sslconn.c \