diff Makefile.am @ 23911:dd4df1a209b7

merge of '44b23c8bda2576a9bfcd3eaa90f9188c455df575' and '7f16ff52262dcf6e66b6fd7796fca4bdd5de76bb'
author Ka-Hing Cheung <khc@hxbc.us>
date Wed, 27 Aug 2008 01:43:09 +0000
parents 6c8be58d0d04
children 27556c2710e3
line wrap: on
line diff
--- a/Makefile.am	Wed Aug 27 01:37:54 2008 +0000
+++ b/Makefile.am	Wed Aug 27 01:43:09 2008 +0000
@@ -30,6 +30,36 @@
 distcheck-hook: libpurple/plugins/perl/common/Purple.pm pidgin/plugins/perl/common/Pidgin.pm
 #	cp libpurple/plugins/perl/common/Gaim.pm $(distdir)/libpurple/plugins/perl/common
 
+version-check:
+# We don't want to release development versions.
+	test x`echo $(PACKAGE_VERSION) | grep dev` = x
+
+# Ensure NEWS has no spaces at the start of a line.
+# Using spaces instead of tabs there is a common mistake.
+	test x`grep "^ " NEWS` = x
+
+# When doing a new minor (or major) release (X.Y.0), there must be a section in
+# ChangeLog.API.
+	echo $(PACKAGE_VERSION) | grep -v "^[0-9]\+\.[0-9]\+\.0$$" >/dev/null || head ChangeLog.API | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
+
+# For all releases, check the ChangeLogs.
+	head ChangeLog | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
+	head ChangeLog.win32 | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
+	head po/ChangeLog | grep "^version $(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" >/dev/null
+
+# Ensure we're working from a tag...
+	test x`mtn automate select t:v$(PACKAGE_VERSION)` = x`mtn automate get_base_revision_id`
+# ... and have no changes in the working copy.
+	test x`mtn diff | grep -v '^#'` = x
+
+release: distcheck packages
+
+packages: version-check
+	gpg -ab pidgin-$(PACKAGE_VERSION).tar.gz
+	gpg -ab pidgin-$(PACKAGE_VERSION).tar.bz2
+	gpg --verify pidgin-$(PACKAGE_VERSION).tar.gz.asc pidgin-$(PACKAGE_VERSION).tar.gz
+	gpg --verify pidgin-$(PACKAGE_VERSION).tar.bz2.asc pidgin-$(PACKAGE_VERSION).tar.bz2
+
 if ENABLE_GTK
 appsdir = $(datadir)/applications
 apps_in_files = pidgin.desktop.in