diff plugins/Makefile.am @ 392:df5127560034

[gaim-migrate @ 402] More updates to plugins committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Mon, 12 Jun 2000 13:07:53 +0000
parents be408b41c172
children debb1c32def3
line wrap: on
line diff
--- a/plugins/Makefile.am	Mon Jun 12 11:30:05 2000 +0000
+++ b/plugins/Makefile.am	Mon Jun 12 13:07:53 2000 +0000
@@ -1,18 +1,28 @@
-SUFFIXES = .c .so
 if GNOMEAPPLET
 CFLAGS += $(GTK_CFLAGS) $(GNOME_INCLUDEDIR) -I../src -DUSE_APPLET
 else
 CFLAGS += $(GTK_CFLAGS) -I../src
 endif
+
+
+
 LDFLAGS += -ggdb $(GTK_LIBS) -shared
+SUFFIXES = .c .so
 .c.so:
-	$(CC) $(CFLAGS) -fPIC -DPIC -o $@ $< $(LDFLAGS)
+	$(CC) $(CFLAGS) -DVERSION=\"$(VERSION)\" -fPIC -DPIC -o $@ $< $(LDFLAGS)
+
+
+
 if PLUGINS
 plugin_DATA = autorecon.so iconaway.so notify.so spellchk.so
 plugindir = $(libdir)/gaim
+
 clean distclean clean-recursive distclean-recursive:
 	$(RM) $(plugin_DATA)
 endif
+
+
+
 EXTRA_DIST = ChangeLog CRAZY HOWTO SIGNALS autorecon.c error.c filectl.c \
 	gaiminc.c iconaway.c lagmeter.c notify.c simple.c spellchk.c \
 	toc_commands.c