diff configure.ac @ 3203:e3cba5bb2d69

[gaim-migrate @ 3220] Fixed timezone stuff again. Maybe this'll do it? committer: Tailor Script <tailor@pidgin.im>
author Jim Seymour <jseymour>
date Sat, 04 May 2002 03:34:46 +0000
parents fdd20785e1e1
children eee7aeeeb70d
line wrap: on
line diff
--- a/configure.ac	Sat May 04 02:06:24 2002 +0000
+++ b/configure.ac	Sat May 04 03:34:46 2002 +0000
@@ -260,6 +260,20 @@
 AC_SUBST(XSS_LIBS)
 
 
+AC_DEFUN(GC_TM_GMTOFF,
+[AC_REQUIRE([AC_STRUCT_TM])dnl
+AC_CACHE_CHECK([for tm_gmtoff in struct tm], ac_cv_struct_tm_gmtoff,
+[AC_TRY_COMPILE([#include <sys/types.h>
+#include <$ac_cv_struct_tm>], [struct tm tm; tm.tm_gmtoff;],
+  ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no)])
+if test "$ac_cv_struct_tm_gmtoff" = yes; then
+  AC_DEFINE(HAVE_TM_GMTOFF)
+fi
+])
+
+GC_TM_GMTOFF
+
+
 
 dnl This was taken straight from X-Chat.
 dnl X-Chat is the greatest application ever, not only