diff pidgin/pixmaps/emotes/default/24/Makefile.am @ 22559:e4b2cbc246da

I'm tired of installing pixmap data that almost never changes. I'm so tired of it, in fact, that I decided to add the ability to disable pixmap installation to our configure script. For the two of us that actually wanted it, here it is.
author John Bailey <rekkanoryo@rekkanoryo.org>
date Sun, 30 Mar 2008 00:19:07 +0000
parents 9347a942b7cd
children 630ad95a8547
line wrap: on
line diff
--- a/pidgin/pixmaps/emotes/default/24/Makefile.am	Sat Mar 29 19:14:17 2008 +0000
+++ b/pidgin/pixmaps/emotes/default/24/Makefile.am	Sun Mar 30 00:19:07 2008 +0000
@@ -190,8 +190,10 @@
     yin-yang.png
 
 
+pidginsmileypix_in_files = default.theme.in
+
+if INSTALL_PIXMAPS
 pidginsmileypixdir = $(datadir)/pixmaps/pidgin/emotes/default
-pidginsmileypix_in_files = default.theme.in
 pidginsmileypix_DATA = \
         $(SMILEYS) \
         theme
@@ -201,5 +203,6 @@
 	    -e 's/^_Description=/Description=/' \
 	    -e 's/^_Author=/Author=/' \
 	$< > $@
+endif
 
-EXTRA_DIST = $(pidginsmileypix_DATA) $(pidginsmileypix_in_files)
+EXTRA_DIST = $(SMILEYS) $(pidginsmileypix_in_files) theme