diff pidgin/pixmaps/emotes/none/Makefile.am @ 22559:e4b2cbc246da

I'm tired of installing pixmap data that almost never changes. I'm so tired of it, in fact, that I decided to add the ability to disable pixmap installation to our configure script. For the two of us that actually wanted it, here it is.
author John Bailey <rekkanoryo@rekkanoryo.org>
date Sun, 30 Mar 2008 00:19:07 +0000
parents 92821180bded
children
line wrap: on
line diff
--- a/pidgin/pixmaps/emotes/none/Makefile.am	Sat Mar 29 19:14:17 2008 +0000
+++ b/pidgin/pixmaps/emotes/none/Makefile.am	Sun Mar 30 00:19:07 2008 +0000
@@ -1,5 +1,7 @@
+pidginsmileypix_in_files = none.theme.in
+
+if INSTALL_PIXMAPS
 pidginsmileypixdir = $(datadir)/pixmaps/pidgin/emotes/none
-pidginsmileypix_in_files = none.theme.in
 pidginsmileypix_DATA = theme
 
 theme: none.theme.in
@@ -7,7 +9,9 @@
 	    -e 's/^_Description=/Description=/' \
 	    -e 's/^_Author=/Author=/' \
 	$< > $@
+endif
 
-EXTRA_DIST = $(pidginsmileypix_DATA) \
+EXTRA_DIST = \
 	$(pidginsmileypix_in_files) \
-	Makefile.mingw
+	Makefile.mingw \
+	theme