diff configure.ac @ 3174:e75b4df7a770

[gaim-migrate @ 3190] This is a dirty hack to attempt to maintain compatibility with autoconf 2.13 and 2.53. We'll eventually get tired of it and drop 2.13 altogether. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Fri, 26 Apr 2002 00:59:30 +0000
parents 76d507a8bc5f
children d62017ec438f
line wrap: on
line diff
--- a/configure.ac	Thu Apr 25 23:25:54 2002 +0000
+++ b/configure.ac	Fri Apr 26 00:59:30 2002 +0000
@@ -1,7 +1,9 @@
 dnl Process this file with autoconf to produce a configure script.
 AC_INIT(src/aim.c)
 AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE([gaim], [0.57-cvs])
+AM_INIT_AUTOMAKE([gaim], [0.57])
+
+AC_PREREQ([2.50])
 
 AC_PATH_PROG(sedpath, sed)
 
@@ -34,8 +36,10 @@
 AC_CHECK_FUNCS(socket strdup strstr atexit getaddrinfo)
 
 dnl Checks for getopt in standard library
-AC_CHECK_FUNCS(getopt_long , , [LIBOBJS="$LIBOBJS getopt.o getopt1.o"] ) 
-AC_SUBST(LIBOBJS)
+AC_CHECK_FUNCS(getopt_long , ,
+AC_LIBOBJ(getopt)
+AC_LIBOBJ(getopt1)) 
+ 
 
 dnl Check for inet_aton
 AC_CHECK_FUNC(inet_aton, , [AC_CHECK_LIB(resolv, inet_aton, , 
@@ -256,35 +260,6 @@
 AC_SUBST(XSS_LIBS)
 
 
-dnl Shamelessly stolen from gnome-pim
-dnl This determines, if struct tm containes tm_gmtoff field
-dnl or we should use extern long int timezone.
-dnl Actually this should go into acinclude.m4
-AC_DEFUN(GC_TIMEZONE,
-[AC_REQUIRE([AC_STRUCT_TM])dnl
-AC_CACHE_CHECK([for tm_gmtoff in struct tm], ac_cv_struct_tm_gmtoff,
-[AC_TRY_COMPILE([#include <sys/types.h>
-#include <$ac_cv_struct_tm>], [struct tm tm; tm.tm_gmtoff;],
-  ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no)])
-if test "$ac_cv_struct_tm_gmtoff" = yes; then
-  AC_DEFINE(HAVE_TM_GMTOFF)
-else
-  AC_CACHE_CHECK(for timezone, ac_cv_var_timezone,
-[AC_TRY_LINK(
-changequote(<<, >>)dnl
-<<#include <time.h>
-extern long int timezone;>>,
-changequote([, ])dnl
-[long int l = timezone;], ac_cv_var_timezone=yes, ac_cv_var_timezone=no)])
-  if test $ac_cv_var_timezone = yes; then
-    AC_DEFINE(HAVE_TIMEZONE)
-  fi
-fi
-])
-
-GC_TIMEZONE
-
-
 
 dnl This was taken straight from X-Chat.
 dnl X-Chat is the greatest application ever, not only