diff configure.ac @ 11999:ea5e84686331

[gaim-migrate @ 14292] This makes tcl/tk buildable for me when using -Werror at configure time. committer: Tailor Script <tailor@pidgin.im>
author Etan Reisner <pidgin@unreliablesource.net>
date Sun, 06 Nov 2005 23:56:40 +0000
parents e094639ab422
children e67993da8a22
line wrap: on
line diff
--- a/configure.ac	Sun Nov 06 23:54:01 2005 +0000
+++ b/configure.ac	Sun Nov 06 23:56:40 2005 +0000
@@ -1201,7 +1201,7 @@
 			oldLIBS=$LIBS
 			LIBS="$LIBS $TCL_LIB_SPEC"
 			AC_TRY_LINK([#include <tcl.h>],
-				    [Tcl_Interp *interp; Tcl_Init(interp)],
+				    [Tcl_Interp *interp=NULL; Tcl_Init(interp)],
 				    [AC_MSG_RESULT([yes]);enable_tcl=yes],
 				    [AC_MSG_RESULT([no]);enable_tcl=no])
 			CPPFLAGS="$oldCPPFLAGS"
@@ -1250,7 +1250,8 @@
 		CPPFLAGS="$CPPFLAGS $TCL_CFLAGS"
 		oldLIBS=$LIBS
 		LIBS="$LIBS $TCL_LIB_SPEC $TK_LIB_SPEC"
-		AC_TRY_LINK([#include <tk.h>], [Tcl_Interp *interp; Tcl_Init(interp); Tk_Init(interp);],
+		AC_TRY_LINK([#include <tk.h>],
+			    [Tcl_Interp *interp=NULL; Tcl_Init(interp); Tk_Init(interp);],
 			    [AC_MSG_RESULT([yes]);enable_tk=yes],
 			    [AC_MSG_RESULT([no]);enable_tk=no])
 		CPPFLAGS="$oldCPPFLAGS"