diff configure.ac @ 22417:eab5bc54e163

Tell gstreamer not to fork; remove the SIGCHLD -> SIGALRM hack, which made Pidgin unrunnable on non-Linux platforms. This involves depending on gstreamer >= 0.10.10, which has been around since 2006-09-14. This isn't a problem, right? Fixes #1496.
author Will Thompson <will.thompson@collabora.co.uk>
date Thu, 06 Mar 2008 11:34:11 +0000
parents a6a24fabf855
children 2c757739ee77 efaecb71baad f2167b8f91ef
line wrap: on
line diff
--- a/configure.ac	Thu Mar 06 07:41:52 2008 +0000
+++ b/configure.ac	Thu Mar 06 11:34:11 2008 +0000
@@ -662,7 +662,7 @@
 	[AC_HELP_STRING([--disable-gstreamer], [compile without GStreamer audio support])],
 	enable_gst="$enableval", enable_gst="yes")
 if test "x$enable_gst" != "xno"; then
-	PKG_CHECK_MODULES(GSTREAMER, [gstreamer-0.10], [
+	PKG_CHECK_MODULES(GSTREAMER, [gstreamer-0.10 >= 0.10.10], [
 		AC_DEFINE(USE_GSTREAMER, 1, [Use GStreamer for playing sounds])
 		AC_SUBST(GSTREAMER_CFLAGS)
 		AC_SUBST(GSTREAMER_LIBS)