diff plugins/Makefile.am @ 11171:ebb02ea3c789

[gaim-migrate @ 13272] Moved DBUS init call from gtkmain.c to core.c Reimplemented DBUS bindings mechamism to use low-level GLib bindings as described in my last blog entry. This way plugins can add new DBUS methods on the fly. Also wrote an example plugin that demonstrate how to do it. committer: Tailor Script <tailor@pidgin.im>
author Piotr Zielinski <zielaj>
date Sat, 30 Jul 2005 00:23:21 +0000
parents 0ff7153e17f3
children f305bcd85dda
line wrap: on
line diff
--- a/plugins/Makefile.am	Fri Jul 29 13:38:00 2005 +0000
+++ b/plugins/Makefile.am	Sat Jul 30 00:23:21 2005 +0000
@@ -46,6 +46,7 @@
 	timestamp.la
 
 autorecon_la_SOURCES    = autorecon.c
+
 extplacement_la_SOURCES = extplacement.c
 gaimrc_la_SOURCES       = gaimrc.c
 history_la_SOURCES      = history.c
@@ -57,6 +58,22 @@
 statenotify_la_SOURCES  = statenotify.c
 timestamp_la_SOURCES    = timestamp.c
 
+if ENABLE_DBUS
+
+CLEANFILES              = dbus-example-bindings.c
+dbus_example_la_LDFLAGS = -module -avoid-version $(GLIB_LIBS) $(DBUS_LIBS)
+dbus_example_la_SOURCES = dbus-example.c
+plugin_LTLIBRARIES     += dbus-example.la
+
+dbus-example-bindings.c: ../src/dbus-analyze-functions.py $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS)
+	cat $(dbus_example_la_SOURCES) $(dbus_example_la_HEADERS) | \
+	$(PYTHON) ../src/dbus-analyze-functions.py --export-only > $@
+
+$(dbus_example_la_OBJECTS) dbus-example.so: dbus-example-bindings.c
+
+
+endif # ENABLE_DBUS
+
 endif # PLUGINS
 
 EXTRA_DIST = \
@@ -78,7 +95,8 @@
 	-I$(top_srcdir)/src \
 	$(DEBUG_CFLAGS) \
 	$(GTK_CFLAGS) \
-	$(PLUGIN_CFLAGS)
+	$(PLUGIN_CFLAGS) \
+	$(DBUS_CFLAGS)
 
 #
 # This part allows people to build their own plugins in here.