diff gtk/plugins/Makefile.am @ 14416:eeca8be382a5

[gaim-migrate @ 17124] This is a Gaim::Gtk perl module for use by gaim plugins to get access to the gtkgaim interface functions. It isn't complete because anything dealing with Gtk widgets themselves doesn't work yet (I need to figure out the best way to do that). To use this a perl plugin just needs to include 'use Gaim::Gtk;' either on top of 'use Gaim;' or instead of it. I'm not done with this yet. At the moment you have to 'use Gaim;' or 'use Gaim::Gtk;' which loads all the parts, I'm planning to let you actually say 'use Gaim::Gtk::Debug;' to just get the gtkdebug.h functions. Though 'use Gaim' would work the same way as always. committer: Tailor Script <tailor@pidgin.im>
author Etan Reisner <pidgin@unreliablesource.net>
date Sat, 02 Sep 2006 05:31:10 +0000
parents 63ef6342db05
children f3d67de8aaf5
line wrap: on
line diff
--- a/gtk/plugins/Makefile.am	Sat Sep 02 04:40:27 2006 +0000
+++ b/gtk/plugins/Makefile.am	Sat Sep 02 05:31:10 2006 +0000
@@ -1,4 +1,4 @@
-DIST_SUBDIRS = cap docklet gevolution gestures musicmessaging ticker
+DIST_SUBDIRS = cap docklet gestures gevolution musicmessaging perl ticker
 
 if BUILD_GEVOLUTION
 GEVOLUTION_DIR = gevolution
@@ -12,12 +12,17 @@
 CAP_DIR = cap
 endif
 
+if USE_PERL
+PERL_DIR = perl
+endif
+
 SUBDIRS = \
 	$(CAP_DIR) \
 	docklet \
+	gestures \
 	$(GEVOLUTION_DIR) \
-	gestures \
 	$(MUSICMESSAGING_DIR) \
+	$(PERL_DIR) \
 	ticker
 
 plugindir = $(libdir)/gaim